Probleme beim Starten der WinTech Software in Windows 10
Probleme beim Starten der WinTech Software in Windows 10
Betrifft:ProVal 3.07 7/6/2015 und Vorgängerversionen, Disclosure & Budgeting Tool 3.07 7/6/2015 und Vorgängerversionen, Grid Agent 3.07 12/18/2014 und Vorgängerversionen, ProVal PS 3.07 7/6/2015 und Vorgängerversionen, ProAdmin 3.07 7/9/2015 und Vorgängerversionen SimMetric 1.18 7/21/2015 und Vorgängerversionen
Symptom
Wenn Sie die WinTech-Software (z. B. ProVal, ProVal PS, ProAdmin, SimMetric) in Windows 10 starten, erhalten Sie die Meldung “closing due to an unrecoverable error”
und die resultierende Fehlerprotokolldatei
(Crash-xxxxxxxxxx.log) enthält “WS FULL: UNABLE TO COMMIT VIRTUAL MEMORY” im Abschnitt “Fehlerdetails”. Beispielsweise:
——————– Fehlerdetails——————–
Zeit: 2015-07-30 18:22:37.644
Label: WS FULL: UNABLE TO COMMIT VIRTUAL MEMORY
Lösung
Option 1: Neuinstallation mit neuem Setup-Programm
Deinstallieren Sie die WinTech-Software und laden Sie eine neue vollständige Installation herunter unter www.winklevoss.com vom 8.10.2015 oder später und installieren Sie diese.
Einschränkungen:
- Gridagent. Eine vollständige Installation vom 8.10.2015 oder später ist noch nicht verfügbar. Bitte verwenden Sie Option 2 für den Grid Agent an.
- Die Neuinstallation funktioniert nur für lokale Installationen, nicht für Netzwerkinstallationen, da die Neuinstallation der Netzwerkkopie die einzelnen INI-Dateien der Benutzer nicht überarbeitet. Netzwerkinstallationen sollten Option 2 verwenden.
Option 2: Manuelle Korrektur an bestehender Installation
-
- Bearbeiten Sie die .ini Dateien für die WinTech-Software, die Sie verwenden.
Software .ini files Default location* ProVal proval.ini,
pvdb.ini**C:\program files (x86)\WinTech\ProVal Disclosure & Budgeting Tool pvdb.ini C:\program files (x86)\WinTech\PVDB Grid Agent grid.ini C:\wintech\grid ProVal PS provalps.ini C:\program files (x86)\WinTech\ProValPS ProAdmin Desktop proadmin.ini,
ft.ini**C:\program files (x86)\WinTech\ProAdmin ProAdmin Server proadmin.ini C:\program files (x86)\WinTech\ProAdminService SimMetric simmetric.ini C:\program files (x86)\WinTech\SimMetric
- Bearbeiten Sie die .ini Dateien für die WinTech-Software, die Sie verwenden.
* Dies ist der Standardspeicherort für eine lokale Installation. Bei Netzwerkinstallationen befindet sich die INI-Datei für jeden Benutzer in einem separaten Ordner.
** pvdb.ini und ft.ini sind möglicherweise nicht vorhanden, wenn das Disclosure & Budgeting Tool (im ProVal-Tool-Menü) und das Fulfillment-Tool (im ProAdmin-Menü Tools) zuvor noch nicht auf diesem System verwendet wurde. Wenn dies der Fall ist, erstellen Sie eine leere Textdatei mit dem Namen pvdb.ini oder ft.ini, bevor Sie mit dem nächsten Schritt fortfahren.
- Fügen Sie dem Abschnitt [Config] der INI-Dateien die folgende Zeile hinzu (Sie müssen einen [Config] -Abschnitt hinzufügen, wenn Sie in Schritt 1 eine neue leere Datei erstellt haben) .TraceLogAlloc = -1
- Speichern Sie die Änderungen in den INI-Dateien
- Starten Sie jedes Softwareprodukt das erste Mal, indem Sie mit der rechten Maustaste klicken und “Als Administrator ausführen” auswählen. Weitere Informationen zu ProVal finden Sie unter Tools> Disclosure & Budgeting. Gehen Sie für ProAdmin Desktop zusätzlich zu Tools> Fulfillment Tool. Dadurch wird die EXE der Software als ActiveX-Server registriert. Es ist nicht erforderlich, die Software als das zweite, dritte usw. Mal als Administrator auszuführen, wenn Sie die Software starten.
Ursache
Ein Speicherzuweisungsfehler tritt beim Start auf, wenn mehr als 2 GB Speicher verfügbar sind. Dies ist auf eine Änderung des Layouts des Systemspeichers unter Windows 10 zurückzuführen.