ProAdmin can’t connect to an Access database after the installation of Office 365.
ProAdmin can’t connect to an Access database after the installation of Office 365.
Last updated: Tuesday, March 27, 2018
Applies to: ProAdmin
Symptom
When connecting to an Access database the error message “Provider cannot be found” occurs.
Solution
Download the Microsoft Access Database Engine and run a quiet installation.
- Microsoft 2016 Redistributable can be downloaded from: https://www.microsoft.com/en-us/download/details.aspx?id=54920 Earlier versions can be found at www.microsoft.com
- Launch an elevated command prompt:
- Click Start, click All Programs, and then click Accessories.
- Right-click Command prompt, and then click Run as administrator.
- If the User Account Controldialog box appears, confirm that the action it displays is what you want, and then click Continue.
- Move the cursor to the bottom left corner and right click
- Select Command Prompt (Admin)
- If the User Account Controldialog box appears, confirm that the action it displays is what you want, and then click Continue.
- At the prompt type in <file location>:\AccessDatabaseEngine.exe /quiet where <file location> is the path to where you downloaded the Microsoft Access Database Engine in step 1. For example:
Windows 7
Windows 10
Cause
Some installations of Office 365 run in an isolated virtual environment on the local operating system and ProAdmin is unable to find the correct drivers to connect.