ProAdmin no puede conectarse a una base de datos Access después de instalar Office 365
ProAdmin no puede conectarse a una base de datos Access después de instalar Office 365
Corresponde a: ProAdmin
Síntoma
Al conectar con una base de datos Access, se muestra el mensaje de error “No se puede encontrar el proveedor”.
Solución
Descargue el motor de base de datos Access de Microsoft y ejecute una instalación desatendida.
1.Puede descargar Microsoft 2016 Redistributable de: https://www.microsoft.com/en-us/download/details.aspx?id=54920. Encontrará las versiones anteriores en www.microsoft.com.
2.Inicie el símbolo de sistema con privilegios elevados:
Windows 7
-
-
- Haga clic en Inicio, después en Todos los programas y, a continuación, en Accesorios.
- Haga clic con el botón derecho en el símbolo del sistema y, a continuación, en Ejecutar como administrador.
- Si aparece el cuadro de diálogo Control de cuentas de usuario, confirme que la acción que muestra es la que desea y, a continuación, haga clic en Continuar.
-
Windows 10
-
-
- Mueva el cursor a la esquina inferior izquierda y haga doble clic.
- Seleccione Símbolo del sistema (administrador).
- Si aparece el cuadro de diálogo Control de cuentas de usuario, confirme que la acción que muestra es la que desea y, a continuación, haga clic en Continuar.
-
3.En el símbolo del sistema, escriba <ubicación del archivo>:\AccessDatabaseEngine.exe /quiet, donde <ubicación del archivo> es la ruta donde descargó el motor de base de datos Access de Microsoft en el paso 1. Por ejemplo:
Causa
Algunas instalaciones de Office 365 se ejecutan en un entorno virtual aislado del sistema operativo local y ProAdmin no puede encontrar los controladores correctos a los que conectarse.